Blogs

Mikrotik Firewall Address list to BGP Network Script (@SAN-IDC)

#Address List to BGP Network by GamerXP Network
#Exclusive for SAN-IDC
#gamerxp.network@gmail.com
#2016

:local bgpip; :set bgpip ""; :local blacktoholeip; :set blacktoholeip "";

:foreach PREFIXID in [/routing bgp network find disabled=no] do={
	:set bgpip [/routing bgp network get $PREFIXID network];
	:if ( [:typeof [:find $bgpip "/32" 0]] = "num" ) do={
		:if ( [:typeof [:find $bgpip ":/32" 0]] = "nil" ) do={
			:set $bgpip [:pick $bgpip 0 ([:len $bgpip]-3)];
			:if ( [:len [/ip firewall address-list find address=$bgpip list=blackhole-bgp]] = 0 ) do={
				:do {

Mikrotik PCC ภาค 2

เป็นข้อความที่ผมใช้ตอบในกลุ่ม Mikrotik108 ครับ (https://www.facebook.com/groups/mikrotik108club/permalink/13097956190436...)

เป็นแบบนี้ครับ per-connection-classifier ในส่วนของ both-addresses-and-ports คือเลือกว่าเราจะเอาอะไรมาเป็นตัวคำนวณในการจัดแบ่ง Connection ครับ

ในกรณีนี้คือ both-addresses-and-ports ก็คือจะเอาทั้ง IP Address ทั้ง SRC และ DST รวมถึง Port มาคิดโดยมีวิธีคิดแบบนี้ครับ

Mikrotik PCC

การทำงานของ Mikrotik Per Connection Classifier